ווטסאפ - לינוקס, BSD, קוד פתוח ותוכנה חופשית בעברית. Whatsup - Linux, BSD, open source and free software in Hebrew

 
 
  כניסת חברים · רישום · שכחתי סיסמה  
tux the penguin
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
אורח · ·
 

הודעה פורסם: 15/03/2018 - 13:12
נושא ההודעה: בלינוקס אין האצה ב-vlc ברזולוציה גבוהה

בחלונות 7 אין בעיה.
כרטיס המסך הוא
GeForce 210
מערכת ההפעלה היא אובונטו 16.04.4
כבר ניסיתי את זה
http://www.ghacks.net/2013/03/05/how-to-enable-gpu-accelerated-decoding-in-vlc
הפוסט הוא מלפני חמש שנים, ותצוגת הווידיאו עדיין "גזורה" (החלק התחתון של הסרט אינו בקצב של החלק העליון).

איך ניתן לבצע התערבות ברמת החומרה של אובונטו?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 15/03/2018 - 17:04
נושא ההודעה:

ציטוט:
נושא ההודעה: בלינוקס אין האצה ב-vlc ברזולוציה גבוהה

אז למה לי יש.. עם https://en.wikipedia.org/wiki/VDPAU

Question
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 16/03/2018 - 08:59
נושא ההודעה: דרך סינפטיק התקנתי את

קוד:

libvdpau1
mesa-vdpau-drivers
vdpau-driver-all

לאחר מכן vlc קרס כל פעם שהרצתי בו סרטון.

גם אחרי שביטלתי האצת חומרה בתוך vlc ,vlc המשיך לקרוס כשהרצתי בו סרטון.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אז למה לי יש..אורח · ·
 

הודעה פורסם: 16/03/2018 - 16:12
נושא ההודעה:

על מנת לקבל לוג שלו, הרץ משורת הפקודה:
קוד:
$ vlc -v

ואולי ניתן יהיה לראות מדוע הוא קורס...
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 16/03/2018 - 20:57
נושא ההודעה: פלט

כעת ה-vlc אינו קורס, אך הסרטון עדיין "גזור", אף על פי שמותקנים
mesa-vdpau-drivers
libvdpau-va-gl1
והדרייברים של nvidia מותקנים. בלינוקס מינט התצוגה ב-vlc תקינה, אבל באובונטו הסרט גזור.

קוד:

vlc -v

VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
[0000000002459088] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[00007f4ee8c016f8] mp4 stream warning: unknown box type sgpd (incompletely loaded)
[00007f4ee8c016f8] mp4 stream warning: unknown box type sbgp (incompletely loaded)
[00007f4ee8c019d8] mp4 demux warning: elst box found
[00007f4ee8c019d8] mp4 demux warning: STTS table of 1 entries
[00007f4ee8c019d8] mp4 demux warning: CTTS table of 10339 entries
[00007f4ee91dabe8] faad decoder warning: decoded zero sample
[00007f4edc0009c8] vdpau_avcodec generic error: decoder profile not supported: 8
[00007f4ef0006d78] core vout display warning: VoutDisplayEvent 'pictures invalid'
[00007f4ee90a4b48] avcodec decoder warning: plane 0 not aligned
[00007f4ee90a4b48] avcodec decoder warning: disabling direct rendering
[0000000002536748] pulse audio output warning: starting late (-12778 us)
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אז למה לי יש..אורח · ·
 

הודעה פורסם: 17/03/2018 - 01:51
נושא ההודעה:

ציטוט:
קוד:
[00007f4edc0009c8] vdpau_avcodec generic error: decoder profile not supported: 8

לא טוב!
הדריבר הקיניני של נוידיה לא מותקן לך ו-vdpau לא עובד.

כך זה עובד אצלי:
קוד:
[00007fc7ecc97148] avcodec decoder: Using NVIDIA VDPAU Driver Shared Library  340.104  Thu Sep 14 16:45:03 PDT 2017 for hardware decoding.


הנה כלי (סקריפט) SGFXI שיעזור לך להתקין כראוי את הדריבר של נוידיה.
Running sgfxi directly

לאחר מכן תתקין mplayer עם כל התלויות שלה, בצורה כזו:
קוד:
$ sudo apt-get install --install-suggests mplayer
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 17/03/2018 - 11:31
נושא ההודעה: הפעלת הסקריפט

קוד:

root: sgfxi

apt-get update successful. Continuing
Updating required package curl now

Preparing to unpack .../libcurl3-gnutls_7.47.0-1ubuntu2.7_amd64.deb ...
Unpacking libcurl3-gnutls:amd64 (7.47.0-1ubuntu2.7) over (7.47.0-1ubuntu2.6) ...
Selecting previously unselected package curl.
Preparing to unpack .../curl_7.47.0-1ubuntu2.7_amd64.deb ...
Unpacking curl (7.47.0-1ubuntu2.7) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up libcurl3-gnutls:amd64 (7.47.0-1ubuntu2.7) ...
Setting up curl (7.47.0-1ubuntu2.7) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
ERROR: (250) You must be out of X/Desktop (like KDE, Gnome, Flux, LXDE etc) to run this feature.
Exiting script now.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אז למה לי יש..אורח · ·
 

הודעה פורסם: 17/03/2018 - 13:55
נושא ההודעה:

קוד:
ERROR: (250) You must be out of X/Desktop

קראת את המדריך?
האם אתה יודע מה זה X?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
הצגת הודעות מלפני:     
מעבר אל:  
כל הזמנים הם GMT + 2 שעות
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
PNphpBB2 © 2003-2004 

תוכן הדיון

  1. אורח
  2. אורח
  3. אורח
  4. אורח [אז למה לי יש..]
  5. אורח
  6. אורח [אז למה לי יש..]
  7. אורח
  8. אורח [אז למה לי יש..]

Google Ads