ווטסאפ - לינוקס, BSD, קוד פתוח ותוכנה חופשית בעברית. Whatsup - Linux, BSD, open source and free software in Hebrew

 
 
  כניסת חברים · רישום · שכחתי סיסמה  
tux the penguin
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
אורח · ·
 

הודעה פורסם: 18/03/2018 - 12:18
נושא ההודעה: התקנת פייתון 3 על רספביאן ושאלת חומרה קטנה?

לגבי רספברי 3 עם מערכת רספביאן - כרגע מותקנת אצלי גרסת 2.7.13 פייתון ואני רוצה לשדרג לפייתון 3 - לא הכי מכיר דביאן וראיתי בגוגל כל מיני הוראות שדורשות התקנה ידנית שלא דרך apt-get... ראשית מענין מדוע השדרוג לא מתבצע דרך sudo apt-get dist-upgrade או אפילו מדוע מלכתחילה לא מותקן פייתון 3? בכל מקרה רציתי לדעת מה הדרך המומלצת להתקנה?

בנוסף - במהלך התקנת דרופל הופיעה הודעת אזהרה לגבי התקנת PHP 32 ביט - כפי שניתן לראות מדובר על בעיה שעלולה לצוץ רק ב 2038... לא הכי מפריע לי אבל למיטב ידיעתי PI3 אמור לעבוד עם 64 ביט, ולא ברור מה הבעיה כאן והאם ניתן לפתור אותה עם שינוי הגדרות או משהו אחר?
https://www.drupal.org/node/2860500
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
mksoftלא בפורום כעתSite Admin ת.הצטרפות: 17/03/2002 · הודעות: 10169 · מיקום: כדור הארץ
 

הודעה פורסם: 18/03/2018 - 13:03
נושא ההודעה:

לגבי פייתון 3, נראה שיש במאגרים את גרסה 3.2, אם תרצה משהו יותר חדש, זה יהיה מסובך יותר.

_________________
הבלוג שלי
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית שלח דוא\ ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 18/03/2018 - 13:39
נושא ההודעה:

מצטער פדיחה שלי Sad סתם התלוננתי על רספביאן ומסתבר שכבר מותקן אצלי Python 3.5.3 ופשוט כשהפעלתי python מהטרמינל אז python 2.7.13 הופעל. כרגע ניסיתי להפעיל מהטרמינל python3 וזה בסדר. דרך אגב: איזו פקודה בודקת אם חבילה מותקנת ואיזו ver?

מקווה שבשאלה על PHP 32 ביט יותר דייקתי Wink ואשמח להסבר

תודה
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 18/03/2018 - 15:40
נושא ההודעה:

אהלן למרות שה3 תומך 64
רספביאן היא 32 מתוך מחשבה על תמיכה לאחור
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
צפריראורח · ·
 

הודעה פורסם: 18/03/2018 - 19:03
נושא ההודעה:

באופן כללי הפקודה לבדיקת גרסה של חבילה מותקנת היא dpkg:
קוד:

dpkg -l python3
dpkg-query -W python3


בדביאן לפחות בינתיים python הוא פייתון 2. כדי להבטיח שמדובר על פייתון 3 יש להריץ python3. אני לא יודע אם ומתי זה ישתנה, אבל לא בגרסה הבאה. שתי החבילות בלתי תלויות וניתנות להתקנה אחת לצד השנייה. חבילות שמתחילות בתחילית python-‎ הן חבילות עם מודולים לפייתון 2 וחבילות עם התחילית python3-‎ הן חבילות לפייתון 3.

מאיר: אתה לא לגמרי מעודכן. פייתון 3 גרסה 3.2 נכלל בדביאן וויזי (7), שלא נתמך בכלל על ARM ונמצא עדיין במעמד LTS בצד (או oldoldstable). בגרסה הקודמת (ג’סי, 8, oldstable) כבר היה 3.4 וביציבה הנוכחית: 3.5 . אז נכון, זה לא 3.6, אבל גם לא כל כך עתיק.

הגרסאות:
https://packages.debian.org/search?keywords=python3

ולהשוואה באובונטו:
https://packages.ubuntu.com/search?keywords=python3

לעניין באג 2038: מערכת הפעלה של 64 ביטים עוזרת אבל לא מונעת את כל הבעיות ומצד שני בעיקרון אפשר להסתדר בלעדיה אם עובדים נכון. הנה שני קישורים עם פרטים על הבעיה ומה עושים איתה (יש המון חומר על כך, זה סתם תוצאה של חיפוש מהיר):
https://lwn.net/Articles/717076/
https://lwn.net/Articles/732794/
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 19/03/2018 - 10:50
נושא ההודעה:

תודה על המידע!
פייתון 3 עובד יפה ומאפשר שליטה על GPIO ברספברי

באג 2038: ניתן להניח שעד השנה ההיא רוב המערכות יהיו עם לפחות 64 ביט (אם לא 128..), וכל עוד לא נשתמש (עד למעבר ל 64 ביט) בתאריך מחוץ לתחום הנל, אני מבין שאין בעיה. מקווה שזה המצב וזה לא נורא וכעת נותר להבין מה אנחנו מפסידים כשעובדים עם מערכת 32 ביטים כשהחומרה מאפשרת 64 ביט? והאם יש תכנון להעביר את רספביאן ל 64 ביט?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
הצגת הודעות מלפני:     
מעבר אל:  
כל הזמנים הם GMT + 2 שעות
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
PNphpBB2 © 2003-2004 

תוכן הדיון

  1. אורח
  2. mksoft
  3. אורח
  4. אורח
  5. אורח [צפריר]
  6. אורח

Google Ads