ווטסאפ - לינוקס, BSD, קוד פתוח ותוכנה חופשית בעברית. Whatsup - Linux, BSD, open source and free software in Hebrew

 
 
  כניסת חברים · רישום · שכחתי סיסמה  
tux the penguin
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
אורח · ·
 

הודעה פורסם: 22/04/2018 - 14:46
נושא ההודעה: כלים לניטור שרת nginx?

עבור שרת במערך: pi3+raspbian+nginx+drupal - אני מחפש המלצות על כלים חינמיים לניתור, איסוף וניתוח נתונים סטטיסטיים וכו. מדובר על הצגת נתונים בזמן אמיתי וגם על מעקב לאורך זמן, ועל כלים שמריצים בקונסול או/גם תוכנות עם GUI.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 23/04/2018 - 09:35
נושא ההודעה:

https://www.nagios.org/

פעם היו משתמשים בנגיוס,
יש לו המון הרחבות וכו׳,
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
mksoftלא בפורום כעתSite Admin ת.הצטרפות: 17/03/2002 · הודעות: 10190 · מיקום: כדור הארץ
 

הודעה פורסם: 23/04/2018 - 09:46
נושא ההודעה:

ל-nginx יש מודול סטטוס שאפשר להפעיל אותו ולקבע מידע בסיסי אודות המתרחש כעת.

יש כלים כמו ngxtop שמנתחים את הלוגים ונותנים מידע "חי" אודות הקורה בו (לא יודע עד כמה הוא עובד, בכל מקרה כדאי לנסות).

אם דואגים שפורמט הלוג יהיה דומה לזה של אפאצ'י, כלים שיודעים לנתח את הלוגים יעבדו גם כאן:
https://en.wikipedia.org/wiki/List_of_web_analytics_software#Free_/_Open_source_(FLOSS)


בנוסף, יש ל-nginx עצמם פתרון כמו Amplify, שהוא hosted solution אצלם. אתה אמור להתקין agent לזה. הם נותנים עד חמישה שרתים חינם.

וכמובן יש את כלי הניטור המורכבים יותר כמו Zabbix ו-nagios¸ למרות שקשה לי להאמין שיהיה לך כדאי להריץ אותם על ה-rPi.

_________________
הבלוג שלי
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית שלח דוא\ ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 23/04/2018 - 22:57
נושא ההודעה:

התקנתי את ngxtop והוא עובד יפה בזמן אמיתי. בהמשך אבדוק מה האפשרויות השונות בפקודה שלו יכולות לתת. אני הולך להפעיל את מודול סטטוס ואני מבין שהוא דרוש גם לצורך הפעלת Amplify - נראית תוכנה יפה עם גרפים וסטטיסטיקות, והיתרון שלא צריך להתקין אותה על ה PI.
נראה שזה כבר יספיק לצרכים שלי מבלי להעמיס יותר מדי את עוגת הפטל דלת הקלוריות...

תודה
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 24/04/2018 - 15:23
נושא ההודעה:

יש לי בעיה בהתקנת Amplify - הלכתי לפי המדריך הבא: https://techblog.co.il/2018/02/amplify-nginx-monitoring-made-easy/
יצרתי ב nginx amplify חשבון והתקנתי עם פקודת curl אבל כשהרצתי את הפקודה הבאה להתקנת agent התקבלה בסעיף האחרון שגיאה (שאולי חשובה או שלא):
קוד:
sudo API_KEY='xxxxxxxxxxxxxxxxxxxxxxx' sh ./install.sh

 --- This script will install the NGINX Amplify Agent package ---

  1. Checking admin user ... root, ok.
  2. Checking API key ... using xxxxxxxxxxxxxxxxxxxx
  3. Checking if uuid should be stored in the config ... False
  4. Checking Python ... found python 2.7
  5. Checking OS compatibility ... raspbian is currently unsupported, apologies!

לאחר שיניתי את הקינפוג של nginx עבור stub_status כפי ששמצוין, שם גם בקובץ: /etc/nginx/conf.d/sub_status.conf וגם בקובץ: /etc/nginx/nginx.conf
ואתחלתי את nginx. כשאני בוחר להמשיך במסך הבא: https://amplify.nginx.com/dashboard
מתבצעת בדיקה של כמה דקות אך בסופה מוצג שוב אותו המסך ללא הצגת השרת. הרצתי את הבדיקה הזו גם ממחשב אחר באותה רשת LAN וגם מה PI עצמו ומתקבלת אותה תוצאה. הבדיקה הזו אמורה לרוץ מכל מחשב שנמצא באותו LAN של השרת ולמצוא את כל השרתים הפעילים - נכון? בכל מקרה לא ברור מה חסר?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 25/04/2018 - 14:28
נושא ההודעה:

כעת אני מנסה להתקין את amplify בשיטה הידנית כפי שמופיע בקישור הבא (נבדוק אחכ איך להפטר מההתקנה הקודמת):
https://github.com/nginxinc/nginx-amplify-doc/blob/master/amplify-guide.md#installing-the-agent-manually
הרצתי כרוט - פקודה ראשונה עברה בסדר:
קוד:
curl -fs http://nginx.org/keys/nginx_signing.key | apt-key add -
O

פקודה שניה גם נראית בסדר:
קוד:
codename=`lsb_release -cs` && \
> os=`lsb_release -is | tr '[:upper:]' '[:lower:]'` && \
> echo "deb http://packages.amplify.nginx.com/${os}/ ${codename} amplify-agent" > \
> /etc/apt/sources.list.d/nginx-amplify.list

cat /etc/apt/sources.list.d/nginx-amplify.list
deb http://packages.amplify.nginx.com/raspbian/ stretch amplify-agent

אבל פקודת העדכון מודיעה על שגיאה במציאת אחת החבילות armhf:
קוד:
apt-get update
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease                                                   
Ign:3 http://packages.amplify.nginx.com/raspbian stretch InRelease                                             
Ign:4 http://packages.amplify.nginx.com/raspbian stretch Release
Ign:5 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent armhf Packages
Ign:6 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent all Packages
Ign:7 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent Translation-en
Ign:8 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent Translation-en_GB
Ign:5 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent armhf Packages
Ign:6 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent all Packages
Ign:7 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent Translation-en
Ign:8 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent Translation-en_GB
Ign:5 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent armhf Packages
Ign:6 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent all Packages
Ign:7 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent Translation-en
Ign:8 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent Translation-en_GB
Ign:5 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent armhf Packages
Ign:6 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent all Packages
Ign:7 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent Translation-en
Ign:8 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent Translation-en_GB
Ign:5 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent armhf Packages
Ign:6 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent all Packages
Ign:7 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent Translation-en
Ign:8 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent Translation-en_GB
Err:5 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent armhf Packages
  404  Not Found
Ign:6 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent all Packages
Ign:7 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent Translation-en
Ign:8 http://packages.amplify.nginx.com/raspbian stretch/amplify-agent Translation-en_GB
Reading package lists... Done
W: The repository 'http://packages.amplify.nginx.com/raspbian stretch Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://packages.amplify.nginx.com/raspbian/dists/stretch/amplify-agent/binary-armhf/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.
root@raspberrypi:/home/pi# apt-get install nginx-amplify-agent

וכשמנסה להתקין את הסוכן זה לא הולך:
קוד:
 apt-get install nginx-amplify-agent
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package nginx-amplify-agent

לא יודע איך ניתן להוריד את החבילה החסרה, ונא לא להתיחס לשאלתי בענין "מציאת השרת באותו LAN" - לא רלוונטי מכיוון שהסוכן יוצר את הקשר לשרת. הבעיה שכרגע לא מצליח להפעיל אותו...
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
צפריראורח · ·
 

הודעה פורסם: 25/04/2018 - 15:01
נושא ההודעה:

מן הסתם מערכת ההפעלה צריכה להיות debian במקום raspbian ואז זה אמור לעבוד.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 25/04/2018 - 16:17
נושא ההודעה:

ציטוט:
מן הסתם מערכת ההפעלה צריכה להיות debian במקום raspbian ואז זה אמור לעבוד.

יש מה לעשות? איזה רעיון להתקנת nginx amplify על raspbian?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 25/04/2018 - 16:47
נושא ההודעה:

ניסית לבנות אותה?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 25/04/2018 - 17:16
נושא ההודעה:

ציטוט:
ניסית לבנות אותה?

לא - יש הסבר איך לבנות בקישורים שציינתי? לא מכיר כל כך דביאן אבל אם תיתן קצה חוט אוכל להמשיך
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 25/04/2018 - 17:50
נושא ההודעה:

האמת עכשיו שאני מסתכל על הפרטים זה סקריפט פיתון אפילו לא צריך לבנות את זה. למערכות הפעלה שלא נתמכות רשמית יש סקריפט התקנה שלא משתמש ב-repositories
https://raw.githubusercontent.com/nginxinc/nginx-amplify-agent/master/packages/install-source.sh
אתה אמור להריץ אותו כ-root
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 25/04/2018 - 18:33
נושא ההודעה:

אז רק צריך לשמור את זה כקובץ ולהריץ אותו כרוט? והאם צריך למחוק את את כל מה שהתקנתי עד עכשיו? איך?
תודה
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 25/04/2018 - 20:37
נושא ההודעה:

שמרתי את תוכן הקישור בקובץ: nginx_amplify.sh ונתתי לו הרשאת הרצה עם chmod +x והרצתי אותו כרוט. התבקשתי להכניס API key והכנסתי את מה שהופיע לי בחשבון באתר של amplify ואחכ בחרתי באפשרות 5 עבור OS כפי שמופיע למטה, והתוכנה החלה לרוץ אבל כפי שניתן לראות בסוף יש הודעת שגיאה שחסר קובץ 'packages/requirements'. ממתין לעזרה מתחנת האם. מהיכן נלקח הסקריפט הנל, אולי יש שם משהו שעשוי לעזור?
תודה

קוד:
 Please select your OS: nginx_amplify.sh

 1. FreeBSD 10, 11
 2. SLES 12
 3. Alpine 3.7
 4. Fedora 24, 26
 5. Other

 ==> 5

Before continuing with this installation script, please make sure that
the following extra packages are installed on your system: git, python 2.6 or 2.7,
python-dev, wget and gcc. Please install them manually if needed.

Continue (y/n)? y

Checking if python 2.6 or 2.7 exists ... yes
Checking if git exists ... yes
Checking if wget exists ... yes
Checking if curl exists ... yes
Checking if gcc exists ... yes
Checking if python-dev exists ... yes

Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting pip
  Using cached https://files.pythonhosted.org/packages/0f/74/ecd13431bcc456ed390b44c8a6e917c1820365cbebcb6a8974d1cd045ab4/pip-10.0.1-py2.py3-none-any.whl
Installing collected packages: pip
Successfully installed pip-10.0.1
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting setuptools
  Downloading https://files.pythonhosted.org/packages/20/d7/04a0b689d3035143e2ff288f4b9ee4bf6ed80585cc121c90bfd85a1a8c2e/setuptools-39.0.1-py2.py3-none-any.whl (569kB)
    100% |████████████████████████████████| 573kB 2.6MB/s
Installing collected packages: setuptools
Successfully installed setuptools-39.0.1
Cloning into 'nginx-amplify-agent'...
remote: Counting objects: 3594, done.
remote: Compressing objects: 100% (162/162), done.
remote: Total 3594 (delta 27), reused 107 (delta 19), pack-reused 3409
Receiving objects: 100% (3594/3594), 1.16 MiB | 148.00 KiB/s, done.
Resolving deltas: 100% (1941/1941), done.
Could not open requirements file: [Errno 2] No such file or directory: 'packages/requirements'
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 26/04/2018 - 10:08
נושא ההודעה:

תערוך בסקריפט ההתקנה את השורה
קוד:
~/.local/bin/pip install --upgrade --target=amplify --no-compile -r packages/requirements


ותשנה אותה ל-[code]~/.local/bin/pip install --upgrade --target=amplify --no-compile -r packages/nginx-amplify-agent/requirements[code][/code]
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
צפריראורח · ·
 

הודעה פורסם: 26/04/2018 - 10:52
נושא ההודעה:

Anonymous :
ציטוט:
מן הסתם מערכת ההפעלה צריכה להיות debian במקום raspbian ואז זה אמור לעבוד.

יש מה לעשות? איזה רעיון להתקנת nginx amplify על raspbian?

מערכת ההפעלה (המשתנה os בסקריפט האמור) אמורה להיות שם debian ולא raspbian, שהיא דביאן עם מעט מאוד תוספות ובסך הכל די תואמת לדביאן.

לכן בשורה בקובץ ‎ /etc/apt/sources.list.d/nginx-amplify.list צריך להיות debian במקום rasbian. אמנם מבט אחד ב:
http://packages.amplify.nginx.com/
יראה שאין שם תת תיקיה בשם raspbian אבל יש שם debian.

כרגיל לאחר עדכון המקורות:
apt update

בכל מקרה, אם אתה לא מעוניין להתקין את החבילה מהמקור שלהם, הסר את הקובץ האמור: מכיוון שיש שגיאה, הוא יוצר דגיאה מכוערת ומיותרת בזמן עדכון מאגר החבילות.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 26/04/2018 - 11:29
נושא ההודעה:

לאחר שערכתי את השורה הבאה בסקריפט:
[code]~/.local/bin/pip install --upgrade --target=amplify --no-compile -r packages/nginx-amplify-agent/requirements[/code
הסקריפט הסתיים בהצלחה אבל בסוף ההרצה יש שגיאת syntax:
[code]creating dist
creating 'dist/nginx_amplify_agent-1.1.0-py2.7.egg' and adding 'build/bdist.linux-armv7l/egg' to it
removing 'build/bdist.linux-armv7l/egg' (and everything under it)
Processing nginx_amplify_agent-1.1.0-py2.7.egg
removing '/usr/local/lib/python2.7/dist-packages/nginx_amplify_agent-1.1.0-py2.7.egg' (and everything under it)
creating /usr/local/lib/python2.7/dist-packages/nginx_amplify_agent-1.1.0-py2.7.egg
Extracting nginx_amplify_agent-1.1.0-py2.7.egg to /usr/local/lib/python2.7/dist-packages
File "/usr/local/lib/python2.7/dist-packages/nginx_amplify_agent-1.1.0-py2.7.egg/amplify/gevent/_socket3.py", line 186
def makefile(self, mode="r", buffering=None, *,
^
SyntaxError: invalid syntax

nginx-amplify-agent 1.1.0 is already the active version in easy-install.pth
Installing nginx-amplify-agent.py script to /usr/local/bin

Installed /usr/local/lib/python2.7/dist-packages/nginx_amplify_agent-1.1.0-py2.7.egg
Processing dependencies for nginx-amplify-agent==1.1.0
Finished processing dependencies for nginx-amplify-agent==1.1.0

--- Finished successfully! ---

To start the Amplify Agent use:

# sudo -u www-data python2.7 /usr/bin/nginx-amplify-agent.py start \
--config=/etc/amplify-agent/agent.conf \
--pid=/var/run/amplify-agent/amplify-agent.pid

To stop the Amplify Agent use:

# sudo -u www-data python2.7 /usr/bin/nginx-amplify-agent.py stop \
--config=/etc/amplify-agent/agent.conf \
--pid=/var/run/amplify-agent/amplify-agent.pid
[/code]
וכשאני מנסה לאתחל את הסוכן מתקבל failed שאולי קשור לשגיאה הנל, או שלא:
[code]$ sudo -u www-data python2.7 /usr/bin/nginx-amplify-agent.py start

Something failed:

Traceback (most recent call last):
File "/usr/local/lib/python2.7/dist-packages/nginx_amplify_agent-1.1.0-py2.7.egg/amplify/agent/common/util/configreader.py", line 53, in test
if not os.path.isfile(config_file) or not os.access(config_file, os.R_OK):
File "/usr/lib/python2.7/genericpath.py", line 37, in isfile
st = os.stat(path)
TypeError: coercing to Unicode: need string or buffer, NoneType found
[/code]

לצפריר: לאחר ששיניתי ל debian בקובץ בצעתי update ויש skipping:
[code]apt-get update
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:3 http://packages.amplify.nginx.com/debian stretch InRelease
Reading package lists... Done
N: Skipping acquire of configured file 'amplify-agent/binary-armhf/Packages' as repository 'http://packages.amplify.nginx.com/debian stretch InRelease' doesn't support architecture 'armhf'[/code]
הנה אישור לשינוי בקובץ:
[code]cat /etc/apt/sources.list.d/nginx-amplify.list
deb http://packages.amplify.nginx.com/debian/ stretch amplify-agent[/code]

ועדיין לא ניתן להריץ את הסוכן:
[code]apt-get install nginx-amplify-agent
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package nginx-amplify-agent
[/code]

תודה לכולם

[code]creating dist
creating 'dist/nginx_amplify_agent-1.1.0-py2.7.egg' and adding 'build/bdist.linux-armv7l/egg' to it
removing 'build/bdist.linux-armv7l/egg' (and everything under it)
Processing nginx_amplify_agent-1.1.0-py2.7.egg
removing '/usr/local/lib/python2.7/dist-packages/nginx_amplify_agent-1.1.0-py2.7.egg' (and everything under it)
creating /usr/local/lib/python2.7/dist-packages/nginx_amplify_agent-1.1.0-py2.7.egg
Extracting nginx_amplify_agent-1.1.0-py2.7.egg to /usr/local/lib/python2.7/dist-packages
File "/usr/local/lib/python2.7/dist-packages/nginx_amplify_agent-1.1.0-py2.7.egg/amplify/gevent/_socket3.py", line 186
def makefile(self, mode="r", buffering=None, *,
^
SyntaxError: invalid syntax

nginx-amplify-agent 1.1.0 is already the active version in easy-install.pth
Installing nginx-amplify-agent.py script to /usr/local/bin

Installed /usr/local/lib/python2.7/dist-packages/nginx_amplify_agent-1.1.0-py2.7.egg
Processing dependencies for nginx-amplify-agent==1.1.0
Finished processing dependencies for nginx-amplify-agent==1.1.0

--- Finished successfully! ---

To start the Amplify Agent use:

# sudo -u www-data python2.7 /usr/bin/nginx-amplify-agent.py start \
--config=/etc/amplify-agent/agent.conf \
--pid=/var/run/amplify-agent/amplify-agent.pid

To stop the Amplify Agent use:

# sudo -u www-data python2.7 /usr/bin/nginx-amplify-agent.py stop \
--config=/etc/amplify-agent/agent.conf \
--pid=/var/run/amplify-agent/amplify-agent.pid
[/code]

[code]$ sudo -u www-data python2.7 /usr/bin/nginx-amplify-agent.py start

Something failed:

Traceback (most recent call last):
File "/usr/local/lib/python2.7/dist-packages/nginx_amplify_agent-1.1.0-py2.7.egg/amplify/agent/common/util/configreader.py", line 53, in test
if not os.path.isfile(config_file) or not os.access(config_file, os.R_OK):
File "/usr/lib/python2.7/genericpath.py", line 37, in isfile
st = os.stat(path)
TypeError: coercing to Unicode: need string or buffer, NoneType found
[/code]
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 26/04/2018 - 11:35
נושא ההודעה:

מצטער שיצא קצת בלגן בפוסט הקודם אבל מקווה שניתן להבין..

דרך אגב: בטעות הצגתי כאן בפוסט החמישי את API_KEY ולאחר מכן מנהל האתר מחק אותו - האם זה מסוכן וכדאי ליצור חשבון חדש עם API_KEY שונה?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 26/04/2018 - 12:10
נושא ההודעה:

הפקודה להתחיל את הסוכן היא 3 שורות אתה כתבת רק את הראשונה
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 26/04/2018 - 12:40
נושא ההודעה:

ציטוט:
הפקודה להתחיל את הסוכן היא 3 שורות אתה כתבת רק את הראשונה

ניסיתי גם את 3 שורות אבל מופיעה אותה שגיאת failed - כנראה בגלל שכבר בשורה הראשונה יש בעיה
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 26/04/2018 - 13:23
נושא ההודעה:

ברור שהחלק הראשון בנפרד נכשל. אני חושב שלא הבנת זה פקודה אחת ארוכה זה לא שלוש פקודות נפרדות. תעתיק את זה בתור שורה אחת ארוכה עם enter יחיד בסוף.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 26/04/2018 - 13:53
נושא ההודעה:

הבנתי אותך - לא ברור למה רשמו את הפקודה ככה - ערכתי את הפקודה (בטלתי את ה '/') ונראה שכעת הפקודה רצה אבל יש להם בעיה בענן (אולי קשור למזג אוויר הסוער Wink ), מקווה שיפתר בהמשך כפי שהם מבטיחים. אעדכן בהמשך:
קוד:
sudo -u www-data python2.7 /usr/bin/nginx-amplify-agent.py start --config=/etc/amplify-agent/agent.conf --pid=/var/run/amplify-agent/amplify-agent.pid

Could not connect to cloud via url https://receiver.amplify.nginx.com:443/1.3

It seems like we have little problems connecting to cloud.
Apologies and bear with us.

We will try to establish a connection once again in a minute.

תודה
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
צפריראורח · ·
 

הודעה פורסם: 26/04/2018 - 15:28
נושא ההודעה:

Anonymous :
לצפריר: לאחר ששיניתי ל debian בקובץ בצעתי update ויש skipping:
קוד:
apt-get update
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease                                                                           
Hit:3 http://packages.amplify.nginx.com/debian stretch InRelease                                                                           
Reading package lists... Done
N: Skipping acquire of configured file 'amplify-agent/binary-armhf/Packages' as repository 'http://packages.amplify.nginx.com/debian stretch InRelease' doesn't support architecture 'armhf'

הנה אישור לשינוי בקובץ:
קוד:
cat /etc/apt/sources.list.d/nginx-amplify.list
deb http://packages.amplify.nginx.com/debian/ stretch amplify-agent


ועדיין לא ניתן להריץ את הסוכן:
קוד:
apt-get install nginx-amplify-agent
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package nginx-amplify-agent



כמו שאפשר לראות, הם בנו את החבילות רק לארכיטקטורות i386 ו־amd64:
http://packages.amplify.nginx.com/debian/dists/stretch/amplify-agent/

החבילה שלהם היא אכן לא מופת לאריזה. לדוגמה, הם יוצרים את המשתמש בסקריפט preinst, דבר הכרחי בחבילות rpm (שם שמות המשתמשים נמצאים כחלק מהגדרות הקבצים עצמם) אבל מיותר בדביאן (שם אם צריכים לשנות הרשאות, צריכים לעשות את זה במפורש ב־postinst).
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 29/04/2018 - 16:00
נושא ההודעה:

מקבל כל הזמן את אותה הודעה:
קוד:
Could not connect to cloud via url https://receiver.amplify.nginx.com:443/1.3

אולי הכתובת לא נכונה או בעיה אחרת...

אבל הכי חשוב שהפורום חזר לחיים, כבר חששתי שהפרסים חטפו אותו Wink
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
הצגת הודעות מלפני:     
מעבר אל:  
כל הזמנים הם GMT + 2 שעות
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
PNphpBB2 © 2003-2004 

תוכן הדיון

  1. אורח
  2. אורח
  3. mksoft
  4. אורח
  5. אורח
  6. אורח
  7. אורח [צפריר]
  8. אורח
  9. אורח
  10. אורח
  11. אורח
  12. אורח
  13. אורח
  14. אורח
  15. אורח [צפריר]
  16. אורח
  17. אורח
  18. אורח
  19. אורח
  20. אורח
  21. אורח
  22. אורח [צפריר]
  23. אורח

Google Ads