ווטסאפ - לינוקס, BSD, קוד פתוח ותוכנה חופשית בעברית. Whatsup - Linux, BSD, open source and free software in Hebrew

 
 
  כניסת חברים · רישום · שכחתי סיסמה  
tux the penguin
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
אורח · ·
 

הודעה פורסם: 22/04/2019 - 10:14
נושא ההודעה: שגיאת קונפליקט בעדכון java

בסיום העדכון האחרון למערכת ארץ' הופיעה השגיאה הבאה:
קוד:
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing jre (12.0.1-1) breaks dependency 'jre<12' required by jdk

אני משתמש לפעמים ב android studio ורציתי לדעת האם jre דרוש לה או לתוכנות אחרות?
אם כן, כיצד ניתן להתגבר על הקונפליקט? אם לא - האם כדאי להסיר אותו?
הנה פלט של java - האם כדאי לעבור ל jdk-11?
קוד:
archlinux-java status
Available Java environments:
  java-11-jdk
  java-8-openjdk/jre (default)

אשמח לקצת סדר ב java - אפרופו ליל הסדר Wink
מועדים לשמחה
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
mksoftלא בפורום כעתSite Admin ת.הצטרפות: 17/03/2002 · הודעות: 10261 · מיקום: כדור הארץ
 

הודעה פורסם: 22/04/2019 - 11:42
נושא ההודעה:

מה חבילות ה־java שמותקנות לך כרגע?

_________________
הבלוג שלי
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית שלח דוא\ ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 22/04/2019 - 13:34
נושא ההודעה:

לא בטוח שזו הפקודה הנכונה להציג את כל חבילות java - אם לא - אז אשמח להתעדכן:
קוד:
pacman -Qs java
local/ca-certificates-utils 20181109-1
    Common CA certificates (utilities)
local/gjs 2:1.56.1-1
    Javascript Bindings for GNOME
local/java-environment-common 3-1
    Common files for Java Development Kits
local/java-runtime-common 3-1
    Common files for Java Runtime Environments
local/jdk 11.0.2-1
    Oracle Java Development Kit
local/jre 11.0.2-1
    Oracle Java Runtime Environment
local/jre8-openjdk 8.u212-1
    OpenJDK Java 8 full runtime environment
local/jre8-openjdk-headless 8.u212-1
    OpenJDK Java 8 headless runtime environment
local/js52 52.9.0-2
    JavaScript interpreter and libraries - Version 52
local/js60 60.6.1-1
    JavaScript interpreter and libraries - Version 60
local/python-sphinxcontrib-jsmath 1.0.1-1
    Sphinx extension which renders display math in HTML via JavaScript
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
astralcלא בפורום כעת ת.הצטרפות: 07/04/2006 · הודעות: 67 ·
 

הודעה פורסם: 23/04/2019 - 01:38
נושא ההודעה:

זה חבילה מAUR, ובגלל צורת ההתקנה משם אי אפשר להתקין שתי חבילות במקביל, התלות של jdk בjre עושה כאן בעיה.
כמעקף אתה יכול להסיר את jdk (תתקין את jdk-openjdk אם משהו דורש jdk דרך java-enviroment)
ואז תשדרג, ובסוף תתקין את jdk מחדש.
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית ביקור באתר המפרסם MSN Messenger  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 23/04/2019 - 13:01
נושא ההודעה:

רגע לאט ברשותך.. הסרתי את חגל עם הפקודה הבאה והנה הפלט:
קוד:
yay -R jdk
checking dependencies...
:: libreoffice-fresh optionally requires java-environment: required by extension-wiki-publisher and extension-nlpsolver

Packages (1) jdk-11.0.2-1

Total Removed Size:  128.05 MiB

:: Do you want to remove these packages? [Y/n]
:: Processing package changes...
(1/1) removing jdk                                                                                                                             [########################################################################################] 100%
:: Running post-transaction hooks...
(1/3) Updating icon theme caches...
(2/3) Arming ConditionNeedsUpdate...
(3/3) Updating the desktop file MIME type cache...

אבל עדיין אני רואה אותו כאן:
קוד:
archlinux-java status
Available Java environments:
  java-11-jdk
  java-8-openjdk/jre (default)

בכלל לא ברור לי מדבריך מה אני אמור לעשות כרגע - מה הכוונה כאן?
ציטוט:
תתקין את jdk-openjdk אם משהו דורש jdk דרך java-enviromen

אשמח להסבר איך להמשיך
תודה
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
astralcלא בפורום כעת ת.הצטרפות: 07/04/2006 · הודעות: 67 ·
 

הודעה פורסם: 24/04/2019 - 19:30
נושא ההודעה:

ציטוט:
בכלל לא ברור לי מדבריך

התכוונתי שאם ההסרה הייתה נכשלת (תלות לא אופציונלית), היית צריך להתקין JDK אחר.

עכשיו שאין את חבילת jdk, השדרוג של jre יעבוד, ואז תוכל להתקין את jdk מחדש.


מהפקודה של archlinux-java, נראה שזה כתוב כאילו הוא עדיין מותקן משום מה (אבל לא בשימוש)... אבל זה לא משפיע על מנהל החבילות
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית ביקור באתר המפרסם MSN Messenger  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 24/04/2019 - 22:55
נושא ההודעה:

הבנתי ובאמת כעת שדרגתי שוב את המערכת ו jre עודכן בהצלחה.
אבל כרגע, לפני שהתקנתי את jdk , אני מקבל:
קוד:
archlinux-java status
Available Java environments:
  java-12-jdk
  java-8-openjdk/jre (default)

אני קצת מבולבל.. אני רואה ש jdk עודכן ל 12 למרות שלכאורה הסרתי אותו ובכלל לא אמור להיות במערכת??
ובכלל - כרגע הדיפולט על openjdk - השאלה היא האם אני צריך את שניהם, או שניתן לעבוד רק עם אחד מהם? נראה לי שצריך לעשות קצת סדר ולא יודע האם אני משתמש בתוכנות שצריכות את שניהם...

תודה
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
mksoftלא בפורום כעתSite Admin ת.הצטרפות: 17/03/2002 · הודעות: 10261 · מיקום: כדור הארץ
 

הודעה פורסם: 27/04/2019 - 00:43
נושא ההודעה:

לפי דעתי החבילה ב-aur התעדכנה (מקודם היה רק ל-jre ו-jdk תלוי בו), לכן העדכון יכל להתבצע.

_________________
הבלוג שלי
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית שלח דוא\ ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 28/04/2019 - 08:56
נושא ההודעה:

ציטוט:
לפי דעתי החבילה ב-aur התעדכנה (מקודם היה רק ל-jre ו-jdk תלוי בו), לכן העדכון יכל להתבצע.

הבנתי - המצב כרגע הוא שהסרתי את jdk (לא ברור למה עדיין מופיע כאילו שהוא מותקן??) -
כרגע נראה שהכל עובד והשאלה היא האם צריך לשנות משהו או להשאיר את זה ככה?
כדאי להעביר את ה default ל java-12-jdk ולמחוק את java-8-openjdk/jre?

יש כל מיני פוסטים ברשת עם בעיה דומה ואולי זה יכול לעזור, לדוגמא:
https://bbs.archlinux.org/viewtopic.php?id=234733

תודה
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
הצגת הודעות מלפני:     
מעבר אל:  
כל הזמנים הם GMT + 2 שעות
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
PNphpBB2 © 2003-2004 

תוכן הדיון

  1. אורח
  2. mksoft
  3. אורח
  4. astralc
  5. אורח
  6. astralc
  7. אורח
  8. mksoft
  9. אורח

Google Ads