ווטסאפ - לינוקס, BSD, קוד פתוח ותוכנה חופשית בעברית. Whatsup - Linux, BSD, open source and free software in Hebrew

 
 
  כניסת חברים · רישום · שכחתי סיסמה  
tux the penguin
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
שמשתמשלא בפורום כעת ת.הצטרפות: 01/12/2014 · הודעות: 50 ·
 

הודעה פורסם: 18/01/2015 - 02:03
נושא ההודעה: [נפתר] כרטיס קול USB. חיבור חם. כיצד?

יש כרטיס קול פנימי במחשב, שהוא הכרטיס שאיתו המחשב הגיע(נמצא על לוח האם).
הכרטיס הזה כמובן עובד היטב. אין איתו בעיה.
קניתי כרטיס קול USB פשוט ואני רוצה שכשאני מחברו למחשב, שהוא יהפוך להיות התקן ברירת המחדל, כך שאם אחבר אליו אוזניות, השמע יצא ממנו.
לאחר שאסיר את ההתקן, אני רוצה שאוטומטית הצלילים יחזרו להיות מופקים מהכרטיס הפנימי שבמחשב.
אני יודע שאפשרי, וראיתי כל מיני תוצאות בחיפושים השונים שלי, אבל לא הצלחתי לגרום לזה לעבוד.

אני עובד עם ארץ' ו/או ג'נטו, אז לא אכפת לי לאיזו הפצה תתייחסו.
גם אם אתם בהפצה אחרת, אל תתביישו לספר איך הצלחתם לגרום לזה לעבוד.
אני מניח שאפשר לעשות התאמות בין ההפצה שלכם לשלי.

בכל אופן, בויקי של ארץ', ראיתי את האפשרות הבאה, שאמורה לגרום ל- udev לזהות שההתקן חובר למחשב ואז לעבור אליו, אבל זה לא עובד לי:
https://wiki.archlinux.org/index.php/Alsa#Hot-plugging_a_USB_sound_card
לא עובד, פירושו, אני לא מצליח לגרום לכרטיס ה- usb להפיק צלילים לאחר הכנסת השורות האלו ככלל חדש כפי שמוסבר שם.
כמובן בצעתי גם הפעלה מחדש...

במקום אחר הסבירו לי שאני צריך למחוק את הקובץ שיצרתי לפי הויקי של ארץ'(לא נורא, ממילא זה לא עובד לי) ולהכנס לתוכנה pulse audio volume control ושם לסמן את התקן ה-usb שלי כהתקן ברירת המחדל/fallback.
להבנתי עשיתי את זה.
יש שם אפשרות ללחוץ על כפתור ליד כל התקן, שאומר להתקן הזה ספציפית להפוך להיות התקן ה- fallback. יש על הכפתור הזה V לבן על רקע ירוק.
בנוסף נאמר לי להוסיף את השורה הבאה:
קוד:
load-module module-switch-on-connect

לקובץ הבא:
קוד:
/etc/pulse/default.pa

זה אמור לגרום להתקן שמוכנס להיות ההתקן הראשי, כלומר זה שעובד כרגע.

לאחר כל זה, בצעתי הפעלה מחדש, כאשר התקן ה-usb לא מחובר למחשב.
לאחר חיבור ה- usb למחשב, לא קורה דבר והוא אינו עובד כשאני משמיע שמע כלשהו במחשב.
הכרטיס הפנימי עובד כרגיל, ללא בעיה(כמו תמיד).

למישהו יש רעיונות?

(אגב, בווינדווס 7, הכרטיס מותקן אוטומטית ועובד היטב Smile)


נערך לאחרונה על-ידי שמשתמש בתאריך 20/01/2015 - 23:34, סך-הכל נערך פעם אחת
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 18/01/2015 - 07:46
נושא ההודעה:

לא ברור הכרטיס עובד לך בכלל כלומר כשאתה בוחר את האפשרות ב- pulse ולא בצורה אוטמאטית?
אם כן אז לא בטוח שיש פתרון בדיוק למה שאתה רוצה (כלומר שזה יעשה אוטמאטית).

ציטוט:

(אגב, בווינדווס 7, הכרטיס מותקן אוטומטית ועובד היטב Smile)


פתרון אפשרי בהחלט תעבור לווינדוס 7.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
מהאורח · ·
 

הודעה פורסם: 18/01/2015 - 08:16
נושא ההודעה:

כמו שהמגיב הקודם רשם רק בלי הציניות.
lsusb dmesg וכ'ו יתנו לך רמזים.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
משה-נחמיאסלא בפורום כעת ת.הצטרפות: 01/09/2010 · הודעות: 296 ·
 

הודעה פורסם: 18/01/2015 - 09:15
נושא ההודעה:

וידאת שהכרטיס עובד על המחשב שלך בלינוקס? זה נשמע כמו בעיית דרייברים
אם לא היית אומר שזה עובד בחלונות הייתי מבקש שתבדוק על חלונות Smile
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
חתוללא בפורום כעת ת.הצטרפות: 03/11/2007 · הודעות: 932 ·
 

הודעה פורסם: 18/01/2015 - 12:15
נושא ההודעה:

הייתה לי בעיה דומה להפעיל אזניות אלחוטיות על ארץ׳. הפתרון היה להתקין את pavucontrol שהוא ממשק גרפי מתקדם ל־pulseaudio ולהגדיר שם את האזניות כהתקן בררת המחדל ליישומים הרצויים.
נסה להתקין אותו ולשחק אתו.
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
שמשתמשלא בפורום כעת ת.הצטרפות: 01/12/2014 · הודעות: 50 ·
 

הודעה פורסם: 18/01/2015 - 12:44
נושא ההודעה:

אז כן. הכרטיס עובד לי בלינוקס.
בעזרת pavucontrol שזה בעצם pulse audio volume control אני יודע שהכרטיס עובד לי בלינוקס.
הפעלתי סרטון ביוטיוב ואז ב- pavucontrol אני רואה את הדפדפן שכרגע מפעיל את הסרטון, ושם אני יכול לבחור ידנית שיעבור להפעיל את הסאונד דרך כל כרטיס שמחובר למחשב.
כמובן שברירת המחדל היא הכרטיס הפנימי.
כשאני מעביר לכרטיס ה- usb, אני אכן שומע צלילים ממנו.
לכן, כן, הכרטיס עובד היטב(גם בג'נטו וגם בארץ').
הבעיה היא שאני לא יודע איך לייצר מעבר אוטומטי אליו כאשר אני מחבר אותו אל המחשב.

לגבי ווינדווס 7, תודה על ההצעה, אבל חזרתי שוב ללינוקס כדי שיהיה מעניין.
עדיין לא החלטתי לחזור לסביבת מייקרוסופט.
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 18/01/2015 - 16:53
6 נושא ההודעה:

זה?...
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
WobnI - workאורח · ·
 

הודעה פורסם: 18/01/2015 - 17:10
נושא ההודעה:

Anonymous :
זה?...


לא כי השואל משתמש ב-PULSEAUDIO.
לשואל, תסתכל בזה: http://stavrakisblog.blogspot.co.il/2012/03/pulseaudio-usb-sound-device-hotplug.html
אולי זה יעזור לך.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
mksoftלא בפורום כעתSite Admin ת.הצטרפות: 17/03/2002 · הודעות: 10251 · מיקום: כדור הארץ
 

הודעה פורסם: 18/01/2015 - 17:13
נושא ההודעה:

האם:
קוד:
pacmd list-modules

מראה שהמודול טעון ?

_________________
הבלוג שלי
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית שלח דוא\ ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
שמשתמשלא בפורום כעת ת.הצטרפות: 01/12/2014 · הודעות: 50 ·
 

הודעה פורסם: 18/01/2015 - 19:58
נושא ההודעה:

WobnI - work :
Anonymous :
זה?...


לא כי השואל משתמש ב-PULSEAUDIO.
לשואל, תסתכל בזה: http://stavrakisblog.blogspot.co.il/2012/03/pulseaudio-usb-sound-device-hotplug.html
אולי זה יעזור לך.


ניסיתי להעתיק את מה שהוא עשה, בהתאמות הדרושות(שם המשתמש שלי שונה וגם תיקייתו כמובן שונה משלי.), יצרתי תיקיית bin כמו שיש לו ושם יש לי את שני קבצי הסקיפט שהוא יצר.
גם בתוכם שיניתי את מה שצריך כדי שיותאם למערכת שלי.
זה לא עובד לי, לצערי.

mksoft, אני קצת מתקשה עם הפקודה שלך כי הפלט מאוד ארוך.
עריכה: הנה הפלט של הפקודה שביקשת:
http://pastebin.com/qBbvDGfZ
ראה את מספר 29:
קוד:
index: 29
        name: <module-alsa-card>
        argument: <device_id="2" name="usb-0d8c_USB_PnP_Sound_Device-00-Device" card_name="alsa_card.usb-0d8c_USB_PnP_Sound_Device-00-Device" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes card_properties="module-udev-detect.discovered=1">
        used: 0
        load once: no
        properties:
                module.author = "Lennart Poettering"
                module.description = "ALSA Card"
                module.version = "5.0"


אני כן יכול לומר לך שכאשר ה- usb תקוע בפנים ואני מפעיל את aplay -l, אני מקבל את זה:


קוד:
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Device [USB PnP Sound Device], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0


הכרטיס שלי הוא כרטיס 2.
ושוב, הכרטיס עובד, אפשר לשמוע דרכו מוזיקה, כאשר מעבירים אליו את המיקוד דרך pavucontrol

אגב, האם כש-pulseaudio מותקנת, אי אפשר להשתמש בכללים של alsa?
האם pulseaudio ממסכת את alsa ואפשר להשתמש רק בה(ב- pulseaudio)?
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
שמשתמשלא בפורום כעת ת.הצטרפות: 01/12/2014 · הודעות: 50 ·
 

הודעה פורסם: 20/01/2015 - 23:25
נושא ההודעה:

אוקיי, זה עובד Smile.
מה שצריך לעשות זה כך:
לסמן ב- pavucontrol שכרטיס ה- usb הוא ה-fallback.
לאחר מכן, מחקתי את ספריית הקונפיגורציה של pulse בספריית הבית(home/).
אצלי זו הייתה הספריה הזו:
קוד:
~/.config/pulse

אגב, זו גם יכולה להיות הספריה הזו:
קוד:
~/.pulse

אבל אצלי היוא הייתה קיימת בתוך ספריית config.

כמו כן, וידאתי שבקובץ:
קוד:
/etc/asound.conf

אין שום דבר, כי זה קובץ של alsa ואני משתמש ב- pulseaudio.
בכל אופן, שמתי לב שאצלי היו שם שתי שורות והפכתי את שתיהן להערה.
(אם במקרה לא אצליח לגרום לכרטיס ה- USB לעבוד, שאוכל להחזיר את מה שהיה שם, ללא קושי)

בנוסף, לקובץ:

קוד:
/etc/pulse/default.pa

הוספתי את השורה הבאה:
קוד:
load-module module-switch-on-connect


לפני השורה הזו:
קוד:
.ifexists module-udev-detect.so


כמו כן, מחקתי את כללי ה- udev שכתבתי עליהם בהודעה הראשונה שלי.

עשיתי הפעלה מחדש כאשר התקן ה- USB לא מחובר למחשב.
הפעלתי מוזיקה ב- VLC והכל עובד היטב עם ההתקן הפנימי של אינטל.
עכשיו חיברתי את התקן ה- USB פנימה והסאונד כבה(!) בהתקן הפנימי, מה שאכן אמור לקרות.
הוצאתי את כבל הרמקולים מהכניסה של ההתקן הפנימי והעברתי אותו לכניסה של התקן ה-USB ויש מוזיקה!
כמה מרגש ומשמח.

הדבר המעט מבעס הוא שזה לא חוזר אחורה באותו אופן, כלומר לאחר שהוצאתי את התקן ה- USB מהמחשב והחזרתי את כבל הרמקולים להתקן הפנימי, המוזיקה לא המשיכה שם(למרות ש-VLC עדיין ניגן אותה), כלומר אין חזרה "חלקה" של הסאונד להתקן הפנימי, כאשר אני מוציא את ה- USB(כמו שקרה לי כאשר הכנסתי את התקן ה- USB פנימה והוא קיבל אליו את המשך המוזיקה שכבר פעלה).
כדי לשמוע שוב בהתקן הפנימי, אני צריך לעצור את הנגן ואז ללחוץ על play שוב והמוזיקה חוזרת.
כמובן שכל הפעלה חדשה של תוכנת וידאו/סאונד אחרת או ניגון חדש של וידאו בדפדפן כלשהו וכו', פועלת היטב.
פשוט הייתי שמח שגם הנגן שמנגן מוזיקה כרגע, או הוידאו שכרגע פועל בדפדפן, ימשיך להיות מנוגן ושלא אצטרך לעוצרו ולהפעילו מחדש, כדי שהוא ישמיע קול שוב.

בכל מקרה, אני מרוצה Smile.
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
הצגת הודעות מלפני:     
מעבר אל:  
כל הזמנים הם GMT + 2 שעות
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
PNphpBB2 © 2003-2004 

תוכן הדיון

  1. שמשתמש
  2. אורח
  3. אורח [מה]
  4. משה-נחמיאס
  5. חתול
  6. שמשתמש
  7. אורח
  8. אורח [WobnI - work]
  9. mksoft
  10. שמשתמש
  11. שמשתמש

Google Ads