ווטסאפ - לינוקס, BSD, קוד פתוח ותוכנה חופשית בעברית. Whatsup - Linux, BSD, open source and free software in Hebrew

 
 
  כניסת חברים · רישום · שכחתי סיסמה  
tux the penguin
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
guestאורח · ·
 

הודעה פורסם: 23/06/2015 - 17:36
נושא ההודעה: בעית התקנת OWNCLOUD על CENTOS 6.4

שלום רב,
אינני איש לינוקס. נתבקשתי לבדוק פתרון שנקרא OWNCLOUD. זהו סו של תחליף לגוגל דרייב המאפשר גם עריכה בו זמנית של מסמכים על ידי משתמשים.
התקנתי כאמור CentOS 6.4 על VirtualBox. ביצעתי עדכון של מערכת ההפעלה והגדרתי אותה לעבודה ברשת.
עקבתי אחר ההוראות ביו טיוב כיצד להתקין Very Happy (בלינק : https://www.youtube.com/watch?v=7P7hU2kI2hc)
הבעיה-לאחר ביצוע של כמעט כל השלבים קיבלתי הודעה לגבי PHP. נאמר בהודעה (אם לתרגם בחופשיות) כי דרושה גרסה 5.4.0 בעוד מותקנת גרסה 5.3.3.
ניסיתי את הפקודה yum install php אך ה"תגובה" היתה שמותקנת החבילה הכי מעודכנת ואין מה לעשות.
שאלתי-האם בגלל שמדובר בגרסה CentOS 6.4 יש מגבלה להתקנה של גרסת PHP שלא ניתן "לעבור מעליה"?
אשמח אם מישהו יודע איך בכל זאת להתקין את שנדרש.
תודה!
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 23/06/2015 - 18:02
נושא ההודעה:

למה לא centos בגרסה החדשה ביותר?
יש כבר 6.5 ואם אני לא טועה שוחרר לא מזמן 7
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 23/06/2015 - 18:10
נושא ההודעה:

Anonymous :
למה לא centos בגרסה החדשה ביותר?
יש כבר 6.5 ואם אני לא טועה שוחרר לא מזמן 7


תודה על תגובתך. אתה צודק אך אלו הם התנאים שהעמידו בפניי בארגון- לעבוד כרגע עם גרסה 6.4.
האם יש בעיה להתקין על גרסה זו PHP בגרסה שלגביה שאלתי בפוסט המקורי?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
mksoftלא בפורום כעתSite Admin ת.הצטרפות: 17/03/2002 · הודעות: 10265 · מיקום: כדור הארץ
 

הודעה פורסם: 23/06/2015 - 23:47
נושא ההודעה:

תצטרך למצוא מאגר חיצוני שמספק את הגרסה הזו (באופן אישי לא נוטה לסמוך על מאגרים חיצוניים, אך אם אין ברירה אז זה מה שיש).

אולי משהו בסגנון בזה:
https://webtatic.com/packages/php54/

גילוי נאות: לא בדקתי ומעולם לא השתמשתי במאגר הזה לכן לא מכיר את איכותו, אמינותו וכן הלאה.

_________________
הבלוג שלי
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית שלח דוא\ ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 24/06/2015 - 00:52
נושא ההודעה:

אם דרושה 5.4, נסה את 5.5 Smile

לא טוב?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
guestאורח · ·
 

הודעה פורסם: 24/06/2015 - 14:25
נושא ההודעה: תודה רבה על הלינק

Anonymous :
אם דרושה 5.4, נסה את 5.5 Smile

לא טוב?


השתמשתי בלינק שסיפקת ולאחר ההתקנה של PHP מגרסה 5.5 מתקבלת השגיאה:
processing conflict: php55w-common-5.5.25-1.w6.x86_64 conflicts php-common < 5.5.0
Finished Dependency Resolution
Error: php55w-common conflicts with php-common-5.3.3-40.el6_6.x86_64

אני משער שזה אומר שצריך להסיר את ה-PHP הישן. לא?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 24/06/2015 - 14:48
נושא ההודעה:

כן, כך זה נראה Smile
מקסמום תחזיר חזרה אם יצוצו בעיות אחרות.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
guestאורח · ·
 

הודעה פורסם: 24/06/2015 - 15:24
נושא ההודעה: תודה על התגובה

Anonymous :
כן, כך זה נראה Smile
מקסמום תחזיר חזרה אם יצוצו בעיות אחרות.


לאור העובדה שאיני איש לינוקס ואיני יודע להסיר חבילות חיפשתי פתרון ומה שבחרתי הוא להריץ את הפקודות הבאות:
yum install yum-plugin-replace

yum replace php-common --replace-with=php55w-common

לאחר מכן הרצתי מחדש את ההתקנה של OWNCLOUD על ידי הפקודה:
yum -y install owncloud

רק שהפעם הוא מצא DEPENDENCY אחר בעייתי:

error: mysql55w-libs conflicts with mysql-libs-5.1.73-5.el6_6.x86_64

תענוג... מה עושים?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
צפריראורח · ·
 

הודעה פורסם: 24/06/2015 - 15:37
נושא ההודעה:

נחזור להתחלה. רצית להתקין OwnClowd. למה התקנת במכונה וירטואלית סנטוס 6.4 (אפילו לא הגרסה העדכנית של סנטוס 6, אבל זו לא הנקודה המהותית כאן)?

למה לא סנטוס 7? (או הפצה אחרת, לדוגמה: דביאן 8 או אובונטו 14.04 או גרסה חדשה יותר)
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
guestאורח · ·
 

הודעה פורסם: 24/06/2015 - 15:42
נושא ההודעה: תודה על תגובה-כך הורו לי בארגון-לא סיפקו סיבה למה הם מחייבים

צפריר :
נחזור להתחלה. רצית להתקין OwnClowd. למה התקנת במכונה וירטואלית סנטוס 6.4 (אפילו לא הגרסה העדכנית של סנטוס 6, אבל זו לא הנקודה המהותית כאן)?

למה לא סנטוס 7? (או הפצה אחרת, לדוגמה: דביאן 8 או אובונטו 14.04 או גרסה חדשה יותר)


אותי לעשות זאת דווקא על CentOS 6.4...

יש המלצות אופרטיביות מה לעשות?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 24/06/2015 - 17:57
נושא ההודעה:

צפריר :
נחזור להתחלה. רצית להתקין OwnClowd. למה התקנת במכונה וירטואלית סנטוס 6.4 (אפילו לא הגרסה העדכנית של סנטוס 6, אבל זו לא הנקודה המהותית כאן)?

למה לא סנטוס 7? (או הפצה אחרת, לדוגמה: דביאן 8 או אובונטו 14.04 או גרסה חדשה יותר)
לא קראת את כל הדיון?
הארגון שבשבילו הוא עובד מחיב אותו להתקין רק גירסה 6.4.


guest
הנה מדריך אחר שאולי יועיל לך
http://superuser.com/questions/615401/upgrading-php-5-3-3-to-5-4-4-in-centos-6-4

כאמור,
הבעיה שלך פה היא שמערכת ההפעלה מורכבת מתלויות רבות, ואם אתה רוצה להתקין גירסה של תוכנה שהיא חדשה יותר מגירסת מערכת ההפעלה עצמה יש בעיה.
במיוחד עם OwnClowd שיש לה כמות גדולה של תלויות, וגם לתלויות יש תלויות.
מדובר בהרבה מאד תוכנה שאתה צריך להחליף, כך שעדיף כבר להחליף את גירסת ה- centos עצמה ולשדרג אותה לגמרי.
יש את מקורות ה-backports שאמורים לתת תשובה חלקית ל"בעיה", אבל גם בהם אין כל דבר.

זה המצב - יש פה בעיה אמיתית לעזור לך Smile
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
הצגת הודעות מלפני:     
מעבר אל:  
כל הזמנים הם GMT + 2 שעות
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
PNphpBB2 © 2003-2004 

תוכן הדיון

  1. אורח [guest]
  2. אורח
  3. אורח
  4. mksoft
  5. אורח
  6. אורח [guest]
  7. אורח
  8. אורח [guest]
  9. אורח [צפריר]
  10. אורח [guest]
  11. אורח

Google Ads