ווטסאפ - לינוקס, BSD, קוד פתוח ותוכנה חופשית בעברית. Whatsup - Linux, BSD, open source and free software in Hebrew

 
 
  כניסת חברים · רישום · שכחתי סיסמה  
tux the penguin
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
שמשתמשלא בפורום כעת ת.הצטרפות: 01/12/2014 · הודעות: 50 ·
 

הודעה פורסם: 15/01/2016 - 00:03
נושא ההודעה: ג'נטו, סמבה(גירסה 3.6). אין שיתוף דרך ווינדווז 7.

זה קרה לי כבר בעבר פה(ונפתר לאחר שדרוג סמבה לגירסה 4.1 ללא שינוי בקובץ ההגדרות):
http://goo.gl/CTwsOG

בכל אופן אתמול שדרגתי את העולם בג'נטו וראיתי שאני משונמך חזרה לסמבה 3.6.
לדעתי זה קשור בפגיעות שנמצאה (גם) בגרסה 4.1 לפי הבאג פה:
https://bugs.gentoo.org/show_bug.cgi?id=568432

אין לי מושג אם אני צודק או לא.
בכל אופן, השורה התחתונה היא ששונמכתי בחזרה לגרסה 3.6, ללא יכולת להתקין גרסה של סמבה מענף 4.2 כי שם יש בעיה אחרת(heimdal ו- krb5 סותרים אחד את השני ואני לא יודע איך לפתור את זה).
גם על זה כבר יש באג די ממזמן(כך ניראה):
https://bugs.gentoo.org/show_bug.cgi?id=490872

אם כן, אני כרגע תקוע על גרסה 3.6 של סמבה ושיתוף התיקיות לא עובד לי.
לא מצליח להכנס דרך ווינדווז 7 לקבצים שנמצאים במחשב של הג'נטו.
זה גם אז לא עבד לי(בפוסט שקישרתי אליו למעלה), כך שאין חדש, אבל עכשיו אני תקוע ללא יכולת לעבור חזרה לענף 4.1 של סמבה(כשבעבר כן הצלחתי).

בניגוד לפעם הקודמת, הפעם רק שירות ה- smbd לא עולה לי(nmbd עולה).
כשאני פוקד:
קוד:
systemctl -l status smbd

אני מקבל:
קוד:
● smbd.service - Samba SMB/CIFS server
   Loaded: loaded (/usr/lib64/systemd/system/smbd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2016-01-14 19:22:22 IST; 4h 37min ago
  Process: 2254 ExecStart=/usr/sbin/smbd -D (code=exited, status=0/SUCCESS)
 Main PID: 2261 (code=exited, status=1/FAILURE)

Jan 14 19:22:21 Mamadoosh systemd[1]: Starting Samba SMB/CIFS server...
Jan 14 19:22:22 Mamadoosh systemd[1]: Started Samba SMB/CIFS server.
Jan 14 19:22:22 Mamadoosh systemd[1]: smbd.service: Main process exited, code=exited, status=1/FAILURE
Jan 14 19:22:22 Mamadoosh systemd[1]: smbd.service: Unit entered failed state.
Jan 14 19:22:22 Mamadoosh systemd[1]: smbd.service: Failed with result 'exit-code'.


גם כשאני מפעיל ידנית את smbd, הוא לא מתרומם.
השגיאה הנ"ל נותרת בעינה.

עזרה, מישהו?

נ.ב.
חשוב מאוד לציין (פעם נוספת) במפורש שבדיוק אותו קובץ הגדרות (smb.conf) עבד לי עד אתמול ללא דופי כשהייתה לי סמבה בגירסה 4.1
לא שונה דבר(בשורוק) מלבד שנמוך סמבה שנכפה עלי.
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 15/01/2016 - 09:43
נושא ההודעה:

ברור מהפלט שישנה תקלה, עכשיו צריך למצוא אותה...
הדרך למצוא תקלה בלינוקס היא עיון בקבצי הלוג השונים.
מה אומר dmesg?
מה כתוב ב ‎/var/log/samba?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 15/01/2016 - 11:56
נושא ההודעה:

זה מה שכתוב ב- smbd.log מהתאריך בו שונמכתי חזרה לגרסה הקודמת של סמבה:
קוד:
[2016/01/13 19:18:06.914492,  0] ../lib/util/become_daemon.c:136(daemon_ready)
  STATUS=daemon 'smbd' finished starting up and ready to serve connectionsFailed to delete pidfile /var/run/samba/smbd.pid. Error was No such file or directory
[2016/01/13 19:54:38.253760,  0] registry/reg_init_basic.c:36(registry_init_common)
  Failed to initialize the registry: WERR_CAN_NOT_COMPLETE
[2016/01/13 22:22:13.046055,  0] registry/reg_init_basic.c:36(registry_init_common)
  Failed to initialize the registry: WERR_CAN_NOT_COMPLETE
[2016/01/14 11:17:08.506602,  0] registry/reg_init_basic.c:36(registry_init_common)
  Failed to initialize the registry: WERR_CAN_NOT_COMPLETE
[2016/01/14 11:33:02.702175,  0] registry/reg_init_basic.c:36(registry_init_common)
  Failed to initialize the registry: WERR_CAN_NOT_COMPLETE
[2016/01/14 11:37:03.071770,  0] registry/reg_init_basic.c:36(registry_init_common)
  Failed to initialize the registry: WERR_CAN_NOT_COMPLETE
[2016/01/14 18:37:15.665143,  0] registry/reg_init_basic.c:36(registry_init_common)
  Failed to initialize the registry: WERR_CAN_NOT_COMPLETE
[2016/01/14 18:46:55.019702,  0] registry/reg_init_basic.c:36(registry_init_common)
  Failed to initialize the registry: WERR_CAN_NOT_COMPLETE
[2016/01/14 19:09:32.993386,  0] registry/reg_init_basic.c:36(registry_init_common)
  Failed to initialize the registry: WERR_CAN_NOT_COMPLETE
[2016/01/14 19:22:22.541531,  0] registry/reg_init_basic.c:36(registry_init_common)
  Failed to initialize the registry: WERR_CAN_NOT_COMPLETE
[2016/01/15 00:00:48.935684,  0] registry/reg_init_basic.c:36(registry_init_common)
  Failed to initialize the registry: WERR_CAN_NOT_COMPLETE
[2016/01/15 11:35:08.482941,  0] registry/reg_init_basic.c:36(registry_init_common)



ב- dmesg למיטב שיפוטי לא רואה משהו שקשור ל- samba.
בצעתי dmesg | grep error ולא ראיתי שיש error שקשור בסמבה.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
powerballאורח · ·
 

הודעה פורסם: 15/01/2016 - 14:26
נושא ההודעה:

אולי זה קשור ל-systemd?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
פעם ראשונה ביםאורח · ·
 

הודעה פורסם: 20/04/2016 - 01:40
נושא ההודעה: סמבה?

יש תוכנת קישור של סיסקו לאוניברסיטה שנקראת סמבה, שגם עושה בעיות בלינוקס (מינט) והתמיכה לא יודעים לפתור אותה. על זה אתה מדבר?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
שמשתמש לא מחובראורח · ·
 

הודעה פורסם: 20/04/2016 - 02:30
נושא ההודעה:

אני מדבר על samba(לא קשור לסיסקו למיטב ידיעתי).
https://www.samba.org/

כמו כן, במקרה הזה, זה אך ורק תלוי בגרסה(כי גרסה 4 כן עובדת. הבעיה היא בגרסה 3 בלבד).
בעבר הצלחתי לפתור את זה ע"י שדרוג לגרסה 4, אבל בחודשים האחרונים החבר'ה מג'נטו מיסכו את גרסה 4 ושונמכתי חזרה ל-3.
בנוסף, יש עימות בין שתי חבילות(שאחת מהן היא תלות של סמבה) שלא יכולות לדור בכפיפה אחת במערכת של ג'נטו.
לכן בלית ברירה אני על סמבה גרסה 3.

אבל ב-ארץ' למשל, יש לי סמבה גרסה 4 ושם השיתוף עובד מעולה.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
פעם ראשונה ביםאורח · ·
 

הודעה פורסם: 27/04/2016 - 22:18
נושא ההודעה: תודה

שמשתמש לא מחובר :
אני מדבר על samba(לא קשור לסיסקו למיטב ידיעתי).
https://www.samba.org/

כמו כן, במקרה הזה, זה אך ורק תלוי בגרסה(כי גרסה 4 כן עובדת. הבעיה היא בגרסה 3 בלבד).
בעבר הצלחתי לפתור את זה ע"י שדרוג לגרסה 4, אבל בחודשים האחרונים החבר'ה מג'נטו מיסכו את גרסה 4 ושונמכתי חזרה ל-3.
בנוסף, יש עימות בין שתי חבילות(שאחת מהן היא תלות של סמבה) שלא יכולות לדור בכפיפה אחת במערכת של ג'נטו.
לכן בלית ברירה אני על סמבה גרסה 3.

אבל ב-ארץ' למשל, יש לי סמבה גרסה 4 ושם השיתוף עובד מעולה.

תודה רבה, לא הבנתי כלום אבל נראה לי שאתה מסתדר
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
שמשתמש לא מחובראורח · ·
 

הודעה פורסם: 28/04/2016 - 02:04
נושא ההודעה:

אם תאמר מה לא הבנת, אנסה לענות לך Smile.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 28/04/2016 - 16:29
נושא ההודעה:

אתה לא יודע לפתור תלויות ?


eix -s samba
קוד:

net-fs/samba
     Available versions:  [M]3.5.21^t [M]3.5.22^t 3.6.25^t 4.2.9 4.2.11 [M
........................



תוריד את המיסוך ותבחר גרסה , זה קורה הרבה שגרסה מסויימת לא טובה וגרסה אחרת בסדר
(זה לא קורה כל כך הרבה , אבל ה portage של gentoo עצום מבחינת הגרסאות מה שאין בכל הפצה.

תבחר גרסה לדוגמה 4.2.9 ממוסכת

emerge --autounmask-write=y =net-fs/samba-4.2.9

לאחר מכן ה etc-update יבקש לשמור שינויים ב porttage/package.unmask \use

תקיש -3
ותקיש y לאישור


תקליד מחדש
emerge --autounmask-write=y =net-fs/samba-4.2.9
או שתלחץ למעלה בחץ ב bash כדי לחזור לפקודה הקודמת .

ותתן ל emerge למקפל , אם יש בעיה שה emerge אומר package-foo חוסם חבילה X בגרסה y .

תשדרג את x לגרסה מעל y או שתסיר את מה שחוסם אותו , או שתסיר את x
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 28/04/2016 - 16:33
נושא ההודעה:

לחלופין אם יש גרסה של samba שאיננה נמצאת ב emerge\portage אתה יכול לקמפל אותה ידנית .

גם אפשרות אבל לא מומלץ ואתה לא נראה לי צריך אתה ב gentoo
לחלץ לתקייה זמנית .

ולהריץ

./configure
make
make install

אם חסר משהו בתלויות של ה configure אתה יכול להתקין את מה שחסר עם emerge


(ממש נדיר ולא נראה לי שאתה צריך סמבה זו חבילה פשוטה )
אתה כנראה לא פותר תלויות נכון ב gentoo

תעדכן את ה portage שלך ,
תחפש תכנות עם eix -s
תעדכן את המאגרים מה portage שרואים ב eix עם
eix-update

ותקפיד להריץ revdep-rebuild לאחר כל עדכון גדול .
ותנקה דברים עם emerge --depclean
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 01/05/2016 - 00:54
נושא ההודעה:

Anonymous :
אתה לא יודע לפתור תלויות ?


eix -s samba
קוד:

net-fs/samba
     Available versions:  [M]3.5.21^t [M]3.5.22^t 3.6.25^t 4.2.9 4.2.11 [M
........................



תוריד את המיסוך ותבחר גרסה , זה קורה הרבה שגרסה מסויימת לא טובה וגרסה אחרת בסדר
(זה לא קורה כל כך הרבה , אבל ה portage של gentoo עצום מבחינת הגרסאות מה שאין בכל הפצה.

תבחר גרסה לדוגמה 4.2.9 ממוסכת

emerge --autounmask-write=y =net-fs/samba-4.2.9

לאחר מכן ה etc-update יבקש לשמור שינויים ב porttage/package.unmask \use

תקיש -3
ותקיש y לאישור


תקליד מחדש
emerge --autounmask-write=y =net-fs/samba-4.2.9
או שתלחץ למעלה בחץ ב bash כדי לחזור לפקודה הקודמת .

ותתן ל emerge למקפל , אם יש בעיה שה emerge אומר package-foo חוסם חבילה X בגרסה y .

תשדרג את x לגרסה מעל y או שתסיר את מה שחוסם אותו , או שתסיר את x


זה מעט מסובך.
יש באג מוכר בעניין הזה(heimdal ו- krb5 לא מתאפשרים יחדיו):
https://bugs.gentoo.org/show_bug.cgi?id=490872
יש שם טלאי שכניראה מאפשר לתקן את זה.
הטלאי הזה מוזכר גם פה:
https://wiki.gentoo.org/wiki/Samba/Samba_4_Migration#Getting_Samba_4
העניין הוא שאין לי כח להתעסק עם זה.
קצת כבד לי והחלטתי לבינתיים להשאר ככה עד שהעניין יפתר בג'נטו עצמה, או עד שיום אחד אאזור מעט כוחות להבין איך מתעסקים עם patch בג'נטו Smile.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 01/05/2016 - 09:44
נושא ההודעה:

patch -p1 <file.patch


בוא נבדוק מה אפשר לעשות אני לא חושב שזה ביג דיל .

אצלי יש מערכת gentoo 64 ביט :
לא מותקן אצלי samba (אני משתמש ב nfs בדרך כלל או ssh)

אבל אני אתקין בשבילך .



א. תתאר איך אתה משתמש עם samba אתה -ניגש מלינוקס אל -מחשבים אחרים ?
אם זה מה שאתה עושה ויש לך samba מותקן כדי לגשת מלינוקס ל win7 אתה צריך לשנות את ההגדרות ב win7 לפחות מ 128ביט חרטא כלשהו

http://www.sevenforums.com/network-sharing/213344-samba-share-not-accessible-windows-7-client.html

אני יודע את זה כי הייתי צריך פעם אחת בחיים שלי להעביר קובץ למחשב עם win7
ומאז זכרתי שיש איזה משהו כזה דבילי .

אם זאת הבעיה אז אין לך בעיה להשאר עם גרסה נוכחית של samba



בכל מקרה אני אתקין samba מגרסה 4X רק כדי להראות לך שזה לא מסובך כמו שזה נראה


ב.
או שאתה ניגש ממחשבים אחרים אל המחשב לינוקס שלך ?
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 01/05/2016 - 11:26
נושא ההודעה:

אני ניגש ממחשב עם windows 7 אל כונן במחשב הלינוקס.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 01/05/2016 - 12:52
נושא ההודעה:

OK
קיבלתי את דבריך .

אני אקמפל עם emerge וארשום כאן פלטים בהמשך .


תן לי את המידע של ה /etc/portage/makc.conf
תרשום מה השורה של ה USE= (אצלך)
שאני אדע איזה דגלים יש לך ב world .


אני אקמפל גרסה 4 ומעלה .
ייתכן שיש באג ב 6.25 ואין עוד גרסה ב 3x ב portage
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
שמשתמשלא בפורום כעת ת.הצטרפות: 01/12/2014 · הודעות: 50 ·
 

הודעה פורסם: 01/05/2016 - 14:02
נושא ההודעה:

שורת ה- USE שלי:
קוד:
USE="icu bindist mmx sse sse2 bluetooth -libav lm_sensors"

ותודה Smile.

עריכה:
יש לי gnome ו- gnome משתמשת ב:
קוד:
* These packages depend on mit-krb5:

gnome-base/gnome-control-center-3.18.2 (kerberos ? app-crypt/mit-krb5)
net-libs/gnome-online-accounts-3.18.4 (kerberos ? app-crypt/mit-krb5)
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 01/05/2016 - 23:47
נושא ההודעה:

האובונטו שלי היום קיבל עדכון לסמבה שפותר את הבעיה -- אולי נכנס גם לארץ'
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 02/05/2016 - 01:36
נושא ההודעה:

Anonymous :
האובונטו שלי היום קיבל עדכון לסמבה שפותר את הבעיה -- אולי נכנס גם לארץ'

בארץ' לא הייתה לי בעיה עם זה. השיתוף בארץ' עובד נהדר.
הבעיה היא בג'נטו...
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 02/05/2016 - 07:59
נושא ההודעה:

בכל מקרה, הייתה בעיה בעדכון הלפני-אחרון של סמבה ב- upstream שגרמה לזה. התיקון של אובונטו נשלח אתמול. מן הסתם גם ג'נטו מסונכרן ל- upstream ואם תעדכן אותו זה יפתר.
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 02/05/2016 - 08:01
נושא ההודעה:

יפה . אתם מדברים על גרסאות בינאריות שמתחזקי החבילות שחררו למאגרים של ubuntu . arch

כאשר אותה גרסה מופצת למליוני משתמשים .


1.ב gentoo מדובר על קמפול חבילה מקוד מקור .
2.בנוסף ב portage של gentoo ישנם הרבה גרסאות (כבבהפצות אחרות יש גרסה אחת)
3.המשתמש ב gentoo יכול לקמפל איזה גרסה שהוא רוצה
4. כל חבילה ניתן לקמפל עם אפשרויות רבות

לדוגמה samba --ssh +krb -x +Y

בארץ מתחזק החבילה החליט על איזה אפשרויות יהיו בעבור רוב המשתמשים ...

ב gentoo המשתמש בוחר ...

5. ב הפצות בינאריות מתחזקי החבילות הפעילו patch על החבילה
בג'נטו לפעמים ... אם יש בעיה המשתמש צריך לפתור את הבעיה עם patch ...
 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
אורח · ·
 

הודעה פורסם: 02/05/2016 - 08:04
נושא ההודעה:

שאלה לפותח האשכול :

מותקנים לך heimdal , krb5

תן לי את הפלטים
קוד:

eix -s krb5

eix -s heimdal

 
   
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
שמשתמשלא בפורום כעת ת.הצטרפות: 01/12/2014 · הודעות: 50 ·
 

הודעה פורסם: 02/05/2016 - 10:08
נושא ההודעה:

הפלט של
קוד:
eix -s krb5

הוא:
קוד:
* app-crypt/mit-krb5
     Available versions:  1.13.2 {doc +keyutils openldap +pkinit selinux test +threads xinetd ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Homepage:            http://web.mit.edu/kerberos/www/
     Description:         MIT Kerberos V

* app-crypt/mit-krb5-appl
     Available versions:  1.0.3
     Homepage:            http://web.mit.edu/kerberos/www/
     Description:         Kerberized applications split from the main MIT Kerberos V distribution

* sys-auth/pam_krb5
     Available versions:  4.6 ~4.7
     Homepage:            http://www.eyrie.org/~eagle/software/pam-krb5
     Description:         Kerberos 5 PAM Authentication Module

[I] virtual/krb5
     Available versions:  0 0-r1 {ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  0-r1(03:14:47 AM 12/22/2014)(ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
     Description:         Virtual for Kerberos V implementation


הפלט של
קוד:
eix -s heimdal

הוא:
קוד:
[I] app-crypt/heimdal
     Available versions:  1.5.3-r2 {X afs +berkdb caps hdb-ldap ipv6 otp +pkinit selinux ssl static-libs test threads ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  1.5.3-r2(02:42:25 PM 08/27/2015)(X berkdb ipv6 pkinit -afs -caps -hdb-ldap -otp -selinux -ssl -static-libs -test -threads ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
     Homepage:            http://www.h5l.org/
     Description:         Kerberos 5 implementation from KTH

* app-mobilephone/heimdall
     Available versions:  ~1.4.0 ~1.4.1 **9999 {qt4 qt5 static-libs}
     Homepage:            http://www.glassechidna.com.au/products/heimdall/
     Description:         Tool suite used to flash firmware onto Samsung Galaxy S devices
 
 צפיה בפרופיל המשתמש שלח הודעה פרטית ביקור באתר המפרסם  
תגובה  עם ציטוט חזרה למעלה
חזרה לתוכן הדיון
הצגת הודעות מלפני:     
מעבר אל:  
כל הזמנים הם GMT + 2 שעות
תגובה לנושא
צפיה בנושא הבא Printable version התחבר כדי לבדוק הודעות פרטיות צפיה בנושא הקודם
PNphpBB2 © 2003-2004 

תוכן הדיון

  1. שמשתמש
  2. אורח
  3. אורח
  4. אורח [powerball]
  5. אורח [פעם ראשונה בים]
  6. אורח [שמשתמש לא מחובר]
  7. אורח [פעם ראשונה בים]
  8. אורח [שמשתמש לא מחובר]
  9. אורח
  10. אורח
  11. אורח
  12. אורח
  13. אורח
  14. אורח
  15. שמשתמש
  16. אורח
  17. אורח
  18. אורח
  19. אורח
  20. אורח
  21. שמשתמש

Google Ads